const regex = /\.\.\/img\/([\w.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.\\.\\\/img\\\/([\\w.]+)', 'g')
const str = `background:#eeeded url(../img/bg.jpg)
background:#eeeded url(../img/bg1.jpg)
background:#eeeded url(../img/bg2.jpg)
<img src="../img/logo.jpg">
<img src="../img/logo1.jpg">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}