re = /\.\.\/img\/([\w.]+)/
str = 'background:#eeeded url(../img/bg.jpg)
background:#eeeded url(../img/bg1.jpg)
background:#eeeded url(../img/bg2.jpg)
<img src="../img/logo.jpg">
<img src="../img/logo1.jpg">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end