package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.\.\/img\/([\w.]+)`)
var str = `background:#eeeded url(../img/bg.jpg)
background:#eeeded url(../img/bg1.jpg)
background:#eeeded url(../img/bg2.jpg)
<img src="../img/logo.jpg">
<img src="../img/logo1.jpg">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}