import re
regex = re.compile(r"\.\.\/img\/([\w.]+)")
test_str = ("background:#eeeded url(../img/bg.jpg)\n"
"background:#eeeded url(../img/bg1.jpg)\n"
"background:#eeeded url(../img/bg2.jpg)\n"
"<img src=\"../img/logo.jpg\">\n"
"<img src=\"../img/logo1.jpg\">\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")