import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.\\.\\/img\\/([\\w.]+)";
final String string = "background:#eeeded url(../img/bg.jpg)\n"
+ "background:#eeeded url(../img/bg1.jpg)\n"
+ "background:#eeeded url(../img/bg2.jpg)\n"
+ "<img src=\"../img/logo.jpg\">\n"
+ "<img src=\"../img/logo1.jpg\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}