$re = '/\.\.\/img\/([\w.]+)/';
$str = 'background:#eeeded url(../img/bg.jpg)
background:#eeeded url(../img/bg1.jpg)
background:#eeeded url(../img/bg2.jpg)
<img src="../img/logo.jpg">
<img src="../img/logo1.jpg">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);