// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.\.\/img\/([\w.]+)").unwrap();
let string = "background:#eeeded url(../img/bg.jpg)
background:#eeeded url(../img/bg1.jpg)
background:#eeeded url(../img/bg2.jpg)
<img src=\"../img/logo.jpg\">
<img src=\"../img/logo1.jpg\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}