# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{{var:([^}=]+)(?:=([^}]*))?}}//gm;t' <<< "This is {{var:my_dog}} and it is {{var:my_awesome}}.
But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}"