$re = '/{{var:([^}=]+)(?:=([^}]*))?}}/m';
$str = 'This is {{var:my_dog}} and it is {{var:my_awesome}}.
But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;