using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{var:([^}=]+)(?:=([^}]*))?}}";
string substitution = @"";
string input = @"This is {{var:my_dog}} and it is {{var:my_awesome}}.
But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}