re = /{{var:([^}=]+)(?:=([^}]*))?}}/m
str = 'This is {{var:my_dog}} and it is {{var:my_awesome}}.
But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result