package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){{var:([^}=]+)(?:=([^}]*))?}}`)
var str = `This is {{var:my_dog}} and it is {{var:my_awesome}}.
But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}