#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m){{var:([^}=]+)(?:=([^}]*))?}}"
Local $sString = "This is {{var:my_dog}} and it is {{var:my_awesome}}." & @CRLF & _
"" & @CRLF & _
"But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)