import re
regex = re.compile(r"{{var:([^}=]+)(?:=([^}]*))?}}", flags=re.MULTILINE)
test_str = ("This is {{var:my_dog}} and it is {{var:my_awesome}}.\n\n"
"But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)