import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{var:([^\\}=]+)(?:=([^\\}]*))?\\}\\}";
final String string = "This is {{var:my_dog}} and it is {{var:my_awesome}}.\n\n"
+ "But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}