# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*(example).*)/~r~6Message found containing $2:\n~r~e$1/gm;t' <<< "This is an example message"