use strict;
my $str = 'This is an example message';
my $regex = qr/(.*(example).*)/mp;
my $subst = '~r~6Message found containing $2:\\n~r~e$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";