import Foundation
let pattern = #"(.*(example).*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This is an example message"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"~r~6Message found containing $2:\n~r~e$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)