re = /(.*(example).*)/m
str = 'This is an example message'
subst = '~r~6Message found containing $2:\\n~r~e$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result