// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*(example).*)").unwrap();
let string = "This is an example message";
let substitution = "~r~6Message found containing $2:\\n~r~e$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}