import re
regex = re.compile(r"(.*(example).*)", flags=re.MULTILINE)
test_str = "This is an example message"
subst = "~r~6Message found containing $2:\\n~r~e$1"
result = regex.sub(subst, test_str)
if result:
print(result)