const regex = /(.*(example).*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*(example).*)', 'gm')
const str = `This is an example message`;
const subst = `~r~6Message found containing $2:\n~r~e$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);