$re = '/(.*(example).*)/m';
$str = 'This is an example message';
$subst = "~r~6Message found containing $2:\n~r~e$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;