import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/folder\\/[^?]+\\?)[^=\\s]+=[^=\\s]+=[^&\\s]+&.*(?=\\s|$)";
final String string = "domain.com/folder/random-text-1?A1=A2=A3&A4\n"
+ "domain.com/folder/random-text-2?B1=B2=B3&B4=B2";
final String subst = "\\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}