import Foundation
let pattern = #"(\/folder\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
domain.com/folder/random-text-1?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4=B2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)