const regex = /(\/folder\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/folder\\\/[^?]+\\?)[^=\\s]+=[^=\\s]+=[^&\\s]+&.*(?=\\s|$)', 'gm')
const str = `domain.com/folder/random-text-1?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4=B2`;
const subst = `\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);