re = /(\/folder\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)/m
str = 'domain.com/folder/random-text-1?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4=B2'
subst = '\\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result