use strict;
my $str = 'domain.com/folder/random-text-1?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4=B2';
my $regex = qr/(\/folder\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)/mp;
my $subst = '\\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";