#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:.*Location1.*?q=(\d+),(\d+))?.*$"
Local $sString = "Text A Location1 More text q=1,2)" Even more text" & @CRLF & _
"Text B" & @CRLF & _
"Text C Location1 More text q=3,4)" Even more text" & @CRLF & _
"Text D"
Local $sSubst = "\1|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)