// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*Location1.*?q=(\d+),(\d+))?.*$").unwrap();
let string = "Text A Location1 More text q=1,2)\" Even more text
Text B
Text C Location1 More text q=3,4)\" Even more text
Text D";
let substitution = "\\1|";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}