$re = '/^(?:.*Location1.*?q=(\d+),(\d+))?.*$/m';
$str = 'Text A Location1 More text q=1,2)" Even more text
Text B
Text C Location1 More text q=3,4)" Even more text
Text D';
$subst = "\1|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;