re = /^(?:.*Location1.*?q=(\d+),(\d+))?.*$/m
str = 'Text A Location1 More text q=1,2)" Even more text
Text B
Text C Location1 More text q=3,4)" Even more text
Text D'
subst = '\\1|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result