import Foundation
let pattern = #"^(?:.*Location1.*?q=(\d+),(\d+))?.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Text A Location1 More text q=1,2)" Even more text
Text B
Text C Location1 More text q=3,4)" Even more text
Text D
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)