using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*Location1.*?q=(\d+),(\d+))?.*$";
string substitution = @"\1|";
string input = @"Text A Location1 More text q=1,2)"" Even more text
Text B
Text C Location1 More text q=3,4)"" Even more text
Text D";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}