package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*Location1.*?q=(\d+),(\d+))?.*$`)
var str = `Text A Location1 More text q=1,2)" Even more text
Text B
Text C Location1 More text q=3,4)" Even more text
Text D`
var substitution = "\1|"
fmt.Println(re.ReplaceAllString(str, substitution))
}