#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\/textarea>"
Local $sString = "<textarea data-match-this="true">{{one}}{{two}}</textarea> " & @CRLF & _
"" & @CRLF & _
"<textarea>{{three}}{{four}}</textarea> " & @CRLF & _
"" & @CRLF & _
"<textarea data-match-this="true">" & @CRLF & _
"{{five}}" & @CRLF & _
"{{six}}{{seven}}" & @CRLF & _
"</textarea> " & @CRLF & _
"" & @CRLF & _
"<textarea>" & @CRLF & _
"{{eight}}" & @CRLF & _
"{{nine}}{{ten}}" & @CRLF & _
"</textarea>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")