# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<textarea[^>]+data-match-this=\"[^\"]+\"[^>]*>.*?<\/textarea>"
test_str = ("<textarea data-match-this=\"true\">{{one}}{{two}}</textarea> \n\n"
"<textarea>{{three}}{{four}}</textarea> \n\n"
"<textarea data-match-this=\"true\">\n"
"{{five}}\n"
"{{six}}{{seven}}\n"
"</textarea> \n\n"
"<textarea>\n"
"{{eight}}\n"
"{{nine}}{{ten}}\n"
"</textarea>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.