import Foundation
let pattern = #"<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\/textarea>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<textarea data-match-this="true">{{one}}{{two}}</textarea>
<textarea>{{three}}{{four}}</textarea>
<textarea data-match-this="true">
{{five}}
{{six}}{{seven}}
</textarea>
<textarea>
{{eight}}
{{nine}}{{ten}}
</textarea>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)