import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<textarea[^>]+data-match-this=\"[^\"]+\"[^>]*>.*?<\\/textarea>";
final String string = "<textarea data-match-this=\"true\">{{one}}{{two}}</textarea> \n\n"
+ "<textarea>{{three}}{{four}}</textarea> \n\n"
+ "<textarea data-match-this=\"true\">\n"
+ "{{five}}\n"
+ "{{six}}{{seven}}\n"
+ "</textarea> \n\n"
+ "<textarea>\n"
+ "{{eight}}\n"
+ "{{nine}}{{ten}}\n"
+ "</textarea>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}