// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ms)<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\/textarea>"#).unwrap();
let string = "<textarea data-match-this=\"true\">{{one}}{{two}}</textarea>
<textarea>{{three}}{{four}}</textarea>
<textarea data-match-this=\"true\">
{{five}}
{{six}}{{seven}}
</textarea>
<textarea>
{{eight}}
{{nine}}{{ten}}
</textarea>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}