re = /<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\/textarea>/m
str = '<textarea data-match-this="true">{{one}}{{two}}</textarea>
<textarea>{{three}}{{four}}</textarea>
<textarea data-match-this="true">
{{five}}
{{six}}{{seven}}
</textarea>
<textarea>
{{eight}}
{{nine}}{{ten}}
</textarea>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end