using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<textarea[^>]+data-match-this=""[^""]+""[^>]*>.*?<\/textarea>";
string input = @"<textarea data-match-this=""true"">{{one}}{{two}}</textarea>
<textarea>{{three}}{{four}}</textarea>
<textarea data-match-this=""true"">
{{five}}
{{six}}{{seven}}
</textarea>
<textarea>
{{eight}}
{{nine}}{{ten}}
</textarea>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}