package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\/textarea>`)
var str = `<textarea data-match-this="true">{{one}}{{two}}</textarea>
<textarea>{{three}}{{four}}</textarea>
<textarea data-match-this="true">
{{five}}
{{six}}{{seven}}
</textarea>
<textarea>
{{eight}}
{{nine}}{{ten}}
</textarea>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}