# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:http:\\/\\/)?(?:www\.)?example\.com\\/g\\/(\d+)\\/\w//gm;t' <<< "http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title"