// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w").unwrap();
let string = "http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}