#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w"
Local $sString = "http://www.example.com/g/1337/Game-Title" & @CRLF & _
"example.com/g/1337/Game-Title" & @CRLF & _
"http://example.com/g/1337/Game-Title" & @CRLF & _
"www.example.com/g/1337/Game-Title"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)