package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w`)
var str = `http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}