const regex = /(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http:\\\/\\\/)?(?:www\\.)?example\\.com\\\/g\\\/(\\d+)\\\/\\w', 'gm')
const str = `http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);