$re = '/(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w/m';
$str = 'http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;