# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w"
test_str = ("http://www.example.com/g/1337/Game-Title\n"
"example.com/g/1337/Game-Title\n"
"http://example.com/g/1337/Game-Title\n"
"www.example.com/g/1337/Game-Title")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.